Sail the 'Verse


The Multiverse is VR supported, and so it requires either OptiFine or Vivecraft for 1.15.2!



Please, check out the map, and join us on Discord!